Delayed Stacks (STX) Deposits and Withdrawals
Incident Report for Coinbase Pro
Resolved
This incident has been resolved.
Posted Oct 25, 2022 - 07:41 PDT
Investigating
We are currently investigating this issue.
Posted Oct 24, 2022 - 15:46 PDT