Delayed ETC deposits
Incident Report for Coinbase Pro
Resolved
This incident has been resolved.
Posted Jul 30, 2020 - 07:28 PDT
Investigating
We are currently investigating this issue.
Posted Jul 30, 2020 - 06:37 PDT
This incident affected: Transfers (Ethereum Classic Network).