Delayed Internet Computer (ICP) Withdrawals
Incident Report for Coinbase Pro
Resolved
This incident has been resolved.
Posted Sep 08, 2021 - 03:23 PDT
Investigating
We are currently investigating this issue.
Posted Sep 08, 2021 - 02:37 PDT
This incident affected: Transfers (ICP Network).