Delayed Bitcoin (BTC) Sends and Receives
Incident Report for Coinbase Pro
Resolved
This incident has been resolved.
Posted Oct 09, 2022 - 22:58 PDT
Investigating
We are currently investigating this issue.
Posted Oct 09, 2022 - 21:25 PDT