Coinbase Pro experiencing issues loading in Google Chrome
Incident Report for Coinbase Pro
Resolved
This incident has been resolved.
Posted Aug 24, 2020 - 10:12 PDT
Investigating
We are currently investigating this issue.
Posted Aug 24, 2020 - 10:00 PDT
This incident affected: Web App.