ADA sends and receives delayed.
Incident Report for Coinbase Pro
Resolved
This incident has been resolved.
Posted Sep 16, 2022 - 20:47 PDT
Investigating
We are currently investigating this issue.
Posted Sep 16, 2022 - 16:26 PDT