Delayed Internet Computer (ICP) Withdrawals
Incident Report for Coinbase Pro
Resolved
This incident has been resolved.
Posted Sep 17, 2021 - 15:32 PDT
Investigating
We are currently investigating this issue.
Posted Sep 17, 2021 - 15:07 PDT
This incident affected: Markets (ICP-USD, ICP-BTC, ICP-EUR, ICP-GBP, ICP-USDT).