Delayed settlement on BTC-USD trades
Incident Report for Coinbase Pro
Resolved
This incident has been resolved.
Posted May 13, 2021 - 05:44 PDT
Identified
The issues has been identified and we are backfilling the impacted BTC-USD trades
Posted May 12, 2021 - 18:21 PDT
This incident affected: Settlement.