Delayed Celo (CELO) Deposits and Withdrawals
Incident Report for Coinbase Pro
Resolved
This incident has been resolved.
Posted Jul 16, 2022 - 13:02 PDT
Update
We are continuing to investigate this issue.
Posted Jul 13, 2022 - 17:38 PDT
Investigating
We are currently investigating this issue.
Posted Jul 13, 2022 - 17:33 PDT