Delayed Cardano (ADA) Withdrawals
Incident Report for Coinbase Pro
Resolved
This incident has been resolved.
Posted Jun 14, 2022 - 20:49 PDT
Investigating
We are currently investigating this issue.
Posted Jun 14, 2022 - 13:13 PDT
This incident affected: Transfers (ADA Network).