Delayed transactions Z-Cash (ZEC)
Incident Report for Coinbase Pro
Resolved
This incident has been resolved.
Posted Jul 26, 2023 - 14:49 PDT
Investigating
Sends are delayed for Z-Cash (ZEC). While we work on a fix, your funds remain secure.
Posted Jul 26, 2023 - 12:40 PDT