Delayed Bitcoin Cash (BCH) Sends/Receives
Incident Report for Coinbase Pro
Resolved
This incident has been resolved.
Posted May 15, 2022 - 16:21 PDT
Investigating
We are currently investigating this issue.
Posted May 15, 2022 - 12:00 PDT