Investigating display issue with USDC balances on Pro and Exchange
Incident Report for Coinbase Pro
Resolved
The display issues for USDC on Coinbase Exchange and Coinbase Pro have been resolved.
Posted Jul 14, 2022 - 16:25 PDT
Identified
We are actively investigating this issue and will post an update when it is resolved. Your funds are safe and you can continue to deposit and withdraw USDC.
Posted Jul 13, 2022 - 16:05 PDT