Kusama Sends and Receives Delayed
Incident Report for Coinbase Pro
Resolved
This incident has been resolved.
Posted Nov 30, 2022 - 20:50 PST
Investigating
We are currently investigating this issue.
Posted Nov 21, 2022 - 07:32 PST