Delayed Send & Receives for Kusama (KSM)
Incident Report for Coinbase Pro
Resolved
This incident has been resolved.
Posted Jul 26, 2022 - 05:29 PDT
Investigating
We are currently investigating the issue.
Posted Jul 26, 2022 - 03:45 PDT