ETC Send / Receive Delayed Due to Network Upgrade
Incident Report for Coinbase Pro
Resolved
This incident has been resolved.
Posted Jun 01, 2020 - 08:09 PDT
Investigating
We are currently investigating this issue.
Posted Jun 01, 2020 - 07:36 PDT
This incident affected: Transfers (Ethereum Classic Network).